FORUM Credit Union's website works best with JavaScript enabled

Important Message on POODLE SSLv3 Security Vulnerability

On October 14, 2014, a security vulnerability named “POODLE” was discovered in SSL v.3.0, a method used by internet browsers for secure communication with websites. This vulnerability could allow an attacker to view your secure communication when browsing the internet.
At FORUM Credit Union, we take the security of our members very seriously, and are taking steps to protect our online users by disabling connections to CU Online via SSL v3.0, effective after Monday, October 20, 2014.  If you are using an up to date version of any internet browser supported by CU Online (see below) you should not be affected by this change. Users of outdated browsers (such as Internet Explorer 6.0 or older) are most vulnerable and are urged to update to the latest version of a supported internet browser.  
Internet Browsers Supported by CU Online
Internet Explorer 8+
Firefox 3.6+
Chrome 11+
Opera 11+
Apple Safari 5+
To learn more about this security vulnerability, please visit: For more information on how to ensure your internet browser is configured correctly, we have found the following resources to be helpful:

Posted: 10/17/2014 with 0 comments

Categories: Security

Blog post currently doesn't have any comments.
 Security code